CorePlayer: Reproductor de vídeo para Tucson 2015-2017 | Página 5 | Foro Hyundai Tucson
  1. ¡Únete a la Comunidad del Hyundai Tucson! ¡Pulsa aquí para registrarte y empezar a participar!
    Descartar aviso

CorePlayer: Reproductor de vídeo para Tucson 2015-2017

Tema en 'Car Audio y Multimedia' iniciado por JKD, 23 May 2018.

  1. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    La verdad es que no he probado mucho la reproducción de streaming más allá de las radios por internet, las cuales sí funcionan. En cuanto al tema de apagar la radio... en realidad no apagas la radio en ningún momento. Cuando pulsas el botón de "Encendido/Apagado" el software principal de Hyundai recibe el evento y notifica al resto de procesos "de Hyundai" tus intenciones. Los procesos afectados toman nota. En el caso del reproductor nativo, pausa el archivo que se está reproduciendo mientras que el proceso principal pone la pantalla en negro y hace MUTE el audio.

    Cuando pulsas el botón de "Encendido/Apagado" de nuevo, vuelve a suceder lo mismo. El proceso principal notifica al resto de módulos, activa la pantalla y activa de nuevo el audio si no estaba en "mute" antes del supuesto apagado. Si el reproductor nativo estaba activo, continua la reproducción.

    Como ves, el equipo ha estado encendido en todo momento aunque tú lo percibas como apagado. En realidad, el equipo se enciende en el momento en el que abres la puerta del coche (sí, antes de arrancar el motor). Dependiendo de lo rápido que seas arrancando el motor o pulsando el botón de encendido del equipo verás el logotipo de Hyundai más o menos tiempo hasta que el equipo termina de arrancar. La mayoría de las veces el equipo consigue bootear antes de que arranques el motor. Y el equipo permanecerá encendido hasta unos 5 o 10 minutos después de apagar el motor.

    Y ... ¿toda esta chapa a qué viene? (te preguntarás). De momento, sólo las aplicaciones de Hyundai reciben la notificación de equipo "apagado/encendido". Ni el servicio de CorePlayer ni el resto de aplicaciones no vinculadas con Hyundai reciben tal notificación, así que no puede saber si el equipo está supuestamente apagado o no, porque sencillamente, nunca está apagado. Por ese motivo, cuando "apagas" el equipo, el reproductor de vídeo sigue haciendo su trabajo y a va seguir leyendo del pendrive hasta que el vehículo corte definitivamente la corriente.

    Si quieres asegurarte de que el pendrive no trabaja cuando apagas el equipo, pausa o cierra la ventana del reproductor de vídeo antes de apagar el motor o de pulsar el botón de "apagado" del equipo :)

    De hecho, recomiendo que se cierre manualmente CorePlayer antes de abandonar el vehículo porque al hacerlo, mi servicio de CorePlayer detecta que el reproductor se ha cerrado y hace una copia del estado actual de reproducción para que la próxima vez que se ejecute el reproductor, se continue el vídeo a partir del punto en el que se cerró. De no hacerlo, cuando el vehículo corta la corriente del equipo sólo las aplicaciones de Hyundai fueron notificadas previamente y tuvieron tiempo de guardar su estado y configuración. Al servicio de CorePlayer no le da tiempo a reaccionar. Por lo que la próxima vez que ejecutes CorePlayer verás que se vuelve a reproducir el mismo vídeo que se reproducía la última vez que cerraste manualmente.
     
    Última edición: 1 Dic 2018
  2. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    Correcto es lo que hago cerrar coreplayer antes de “apagar”
     
  3. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    Tengo la sd original guardada y sin modificaciones y tengo una sd con los mapas actualizados y el coreplayer
     
  4. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    Por casualidad sabes algo de este reproductor?

    Da la sensacion de ir mas fluido no? Tucson player creo que leo en el icono
     
  5. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    Por favor, usad el motor de búsqueda del foro para no mezclar aplicaciones :)
    TUCSONPLAYER
     
  6. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    Sorry, no lo mire, gracias de nuevo
     
  7. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    Hola primero gracias de nuevo por todo, y segundo, esto que comentas para que no autoabriera cada vez que arrancas la radio el coreplayer, donde iria ese comando de norun?
     
    A MARKITOS le gusta esto.
  8. MARKITOS

    MARKITOS Forero Activo

    Ubicación:
    Madrid
    Motor:
    1.6 GDi 131 CV
    Versión:
    Tecno
    Color:
    Ara Blue
    Eso me interesa, JKD como se pasa-modifica-crea... ese parametro NORUN para que solo se inicie el BootLoader pero NO el reproductor en
    tu creacion "coreplayer_full 1.0.0.5"

    Graciasssssss
     
  9. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    Como puedo hacer para que no pase lo de las sombras al poner la camara trasera? Tengo tu coreplayer con los archivos modificados para que funcione con mapas y al tener un video y poner la marcha atras y activar la camara salen las sombras estas igual que en tu video, veo que dices que tenias una solucion pero no encuentro el que hay que hacer, gracias
     
  10. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    No está resuelto. Creí que era un problema que afectaba a algunos modelos de Kia, lo que indicaría que habría alguna pequeña diferencia de software al no ser el mismo equipo pero también ocurre en algún Tucson. En mi Tucson funciona bien siempre. Da igual la operación que realice. Así que no veo dónde está el problema. He solicitado hace unos días a un usuario con Tucson uno de los vídeos que reproduce con los que le da el problema para ver si se trata del formato interno de vídeo y tratar de generar el mismo resultado en mi coche pero aún no he recibido respuesta.

    Lo cierto es que, hasta que no dé con la forma de generar el mismo problema en mi coche o que alguien me dejara hacer pruebas en su vehículo a sabiendas de que le falla, no sé si voy a encontrar la raíz del problema. Al menos, de momento.
     
  11. Guanchito03

    Guanchito03 Forero Activo

    Ubicación:
    Tenerife
    Mañana te envío el vídeo. Pensé que era solo con un vídeo pero en en varios. También pasa que un video si lo ejecuto desde Windows se ve bien con el Coreplayer pero desde Tucsy se ve mal.
     

    Adjuntos:

  12. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    A mi me pasa con la codificacion que pones tu en el post de reescalado de videos para tucson
    a mi esto no me pasa, me pasa igual que el video de jdk que sale como sombras negras y uso el software y configuracion del post que hay de reescalar los videos, tengo que hacer mas pruebas pero creo que solo pasa si uso el coreplayer que se arranca nada mas encender la radio, si lo cierro, lo vuelvo a abrir y entonces doy marcha atras creo que va bien mañana confirmo
     
  13. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    Me consta (porque me sucede también) que si se ejecuta CorePlayer cuando se está escuchando la radio, el reproductor de mp3 de Hyundai no recibe ciertos eventos de los botones. Forzar el canal de audio a MEDIA y forzar la visualización del reproductor de Hyundai no parecen solventarlo, ya que es precisamente lo que hace el lanzador de CorePlayer antes de ejecutar el reproductor de vídeo. Además, el lanzador de CorePlayer fuerza a que el reproductor nativo reproduzca el mp3 en curso durante unos milisegundos para ver si actualiza su estado y el resto del software de Hyundai reconoce que ya no está en "modo radio" pero el problema persiste. Cuando cierro el reproductor de vídeo y tengo en pantalla el reproductor nativo de Hyundai, al tocar los botones de siguiente/anterior canción, el reproductor no responde. Por eso no responde el cambio de canción en el reproductor de vídeo. Y esto, me consta que sucede cuando se ejecuta CorePlayer y se está escuchando la radio. En este caso, el problema se resuelve fácilmente pulsando el botón MEDIA para mostrar el reproductor nativo antes de ejecutar CorePlayer.

    Pero ese problema no afecta a la marcha atrás.
     
  14. leyendas22

    leyendas22 Forero Activo

    Motor:
    1.6 TGDi 176 CV
     

    Adjuntos:

    • 1.jpg
      1.jpg
      Tamaño de archivo:
      65,5 KB
      Visitas:
      24
    • 2.jpg
      2.jpg
      Tamaño de archivo:
      69,5 KB
      Visitas:
      20
  15. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    Creo que e dado con la solución de las sombras cuando se activa la cámara trasera, me falta probar mas pero de momento pasa el video al background del todo, el problema era una opción de coreplayer que esta en el menu superior de coreplayer en tools-settings y aquí la opción “Show video in background” la e desmarcado que va por defecto marcada, una vez quitada de momento parece que hace bien lo de apartar el video completamente al meter la marcha atrás, los que teníais el mismo fallo probadlo
     
    Última edición: 23 Dic 2018
    A Guanchito03 le gusta esto.
  16. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    ¿Has probado a visualizar simultaneamente el vídeo y los mapas y a pulsar sobre cualquier punto del mapa? Cuando pones la marcha atrás, ¿sigue escuchándose el audio?
     
  17. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    Si se sigue escuchando pero con el volumen mas bajo cuando quitas la camara vuelve al volumen normal de momento quitando esa opcion va bien y se ha solucionado eso de los bordes negros del video esas sombras que salian
     
    Última edición: 23 Dic 2018
  18. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    Localizaré esa opción en el archivo de configuración y me aseguraré de que el lanzador de CorePlayer deshabilite dicha opción antes de ejecutar el reproductor. A ver qué resultados da.
     
  19. hannibal1986

    hannibal1986 Forero Activo

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno 7DCT
    Color:
    Moon Rock
    Desde que e desactivado esa opcion va todo bien de momento lo que e probado, antes con la opcion activada me salia el video encima de la camara trasera siempre de la misma forma que sale en tu video
     
  20. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    Vamos a ver. Tienes razón en que esa opción activada es la que causa el problema. He localizado cuál es la opción en cuestión y cotejado el archivo de configuración que genera mi lanzador de CorePlayer y resulta que mi lanzador establece esa opción como desactivada por defecto. Por lo tanto, entiendo que has tenido que activarla tú de alguna manera. Mi lanzador procura no pisar la configuración existente modificada.

    De todas formas, voy a modificar el lanzador para que se asegure que la configuración vigente tenga esa opción desactivada. :thumbsup:
     
Este sitio usa cookies, propias y de terceros. Si se continúa con nosotros entendemos que se acepta el uso de cookies. Aceptar Más información