Desprotección DRM de mapas y tarjeta SD | Página 2 | Foro Hyundai Tucson

Desprotección DRM de mapas y tarjeta SD

Tema en 'Car Audio y Multimedia' iniciado por JKD, 21 Sep 2016.

  1. darkhugo

    darkhugo Forero Activo

    Ubicación:
    Elche
    Motor:
    1.6 GDi 131 CV
    Versión:
    Klass
    Color:
    Polar White
    Se nota que algunos entendéis un «poquito» de programación.

    Yo me considero un usuario de tecnologías con conocimientos intermedios, pero leo todo eso y que me quedo con la boca abierta y cara de tonto.

    Así que muchas gracias a los que investigan y comparte con el resto de nosotros su trabajo.
     
    A kike, Wolfran93 y Erperdi les gusta esto.
  2. Connermc

    Connermc Forero Activo

    Una pena que no valgan los mapas... hubiera sido una maravilla!!
     
    A kike le gusta esto.
  3. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    Después de realizar unas comprobaciones con @Sandrovich en su versión de software podemos afirmar lo siguiente:
    • En el software antiguo, versión TL.EU.SOP.20.003 y anteriores, el truco del archivo AMK.LMF no funcionará puesto que su versión de LgeDRMKey.exe se limita a verificar que la SD es original.
    • El truco de modificar LMV.LMF para que unos mapas descargados funcionen en la tarjeta original funcionaría.
    • Para poder usar una tarjeta no original habría dos posibilidades. O bien parchear el ejecutable LgeDRMKey.exe de dicha versión o bien utilizar la última versión de dicho programa. Las pruebas demuestran que la última versión de LgeDRMKey es compatible hacia atrás por lo que, sustituyendo ese programa por el de la última versión, el truco del archivo AMK.LMF funcionará y permitirá el uso de SD no originales.
    Esta noche publico el programa en los posts iniciales. :)
     
    A kike, darkhugo y Wolfran93 les gusta esto.
  4. awitawena

    awitawena Forero Novato

    Estáis haciendo un trabajo excelente. Yo acabo de llegar a este foro, mi Tucson tiene sólo 2 semanas, pero me quedo boquiabierto al ver la magnitud del trabajo que realizáis, las horas de tiempo de búsqueda de información, análisis y pruebas hasta que dais una explicación para los usuarios "no iniciados", entre los que me encuentro.

    Una vez que estén todas las pruebas hechas, se podría montar un manual en pdf con fotos y explicación, junto a los archivos necesarios para poder hacerlo? Yo aún no he visto todas las cosas que trae el coche, imagino que tendrá la última versión, pero tengo que comprobarlo. En cualquier caso, he visto ya que lo de registrarse en Navteq en la web es un timo porque te redirigen al taller, así que no ganamos nada.

    Y en el conce, antes de comprar el coche, les pedí que por qué no podía ver los radares fijos, cuando en un peugeot 208 normalito se podía. Me dijeron que habría que sincronizar los servicios de TomtomLive desde el móvil y vincularlo por wifi. ¿wtf? Esa explicación vale para algo? No quiero meter en este post basura para no desvirtuarlo, pero si me podéis orientar sobre esto, no digo radares móviles, pero los radares que están "de toda la vida" en los mismos sitios en la carretera, su ubicación es algo público, no hay manera de que aparezcan en el navegador?


    Gracias,
    Un saludo
     
    A kike le gusta esto.
  5. Daviqui

    Daviqui Forero Activo

    Ubicación:
    Aragon
    Motor:
    1.7 CRDi 141 CV
    Versión:
    Tecno
    Color:
    Moon Rock
    Hola JKD una buena explicación pero a mi me entregaron el coche el dias 7 de Noviembre y la tajeta que me dieron con la ultima actualizacion con un numero de serie y todo el rollo y no se puede copiar, bueno copiar si pero si pongo la que he copiado en el navegador me dice compruebe que haya puesto la tarjeta OK o sea que la copia no funciona y ya te digo es la ultima actualizacion la B1. Ademas ya te digo es muy rara hay una cantidad de numeros y licencias, seguro que si la clonase a lo mejor si que funcionaria la clonada no lo he probado. Saludos
     
  6. Daviqui

    Daviqui Forero Activo

    Ubicación:
    Aragon
    Motor:
    1.7 CRDi 141 CV
    Versión:
    Tecno
    Color:
    Moon Rock
    Hola solo has de compartir la wifi de tu movil con el navegador y configurar en el navegador que detecte los radares, nada mas este rollo que te dijo del TomtomLive nada olvidate, yo tengo un modem tp-link con tajeta sim (Movil) y funciona perfectamente.
     
  7. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    Comprueba que en la carpeta LGENavi/LIMF/ de la tarjeta clonada se encuentra el archivo AMK.LMF porque no todos tienen por qué tenerla aunque tengan la última versión.
     
  8. Daviqui

    Daviqui Forero Activo

    Ubicación:
    Aragon
    Motor:
    1.7 CRDi 141 CV
    Versión:
    Tecno
    Color:
    Moon Rock
    No la clone solo la copie, hare otra copia mañana porque con la que esta cayendo de agua no voy a atravesar la calle para ir al garaje, como te digo hare la copia mañana y mirare lo que me dices y te comento.
    P.D.: Si esto funciona quiere decir que podriamos meter otros mapas e incluso nos marcaria los radares?
     
  9. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    Mmm si encontrases mapas más actualizados si, podrías usarlos. El tema de los radares... Por el momento sólo se pueden meter como POIs. He podido ver en el código que nuestro navegador parece soportar radares fijos. Al menos en cierta librería, trata de localizar la base de datos CAM.db a partir de la cual genera un índice llamado CAM.idx. En nuestro equipo esa base de datos no está. Intuyo que al añadir los servicios de TOMTOM se han desentendido de esa funcionalidad local. Pero en teoría, el programa si está preparado para meter radares.
     
  10. Daviqui

    Daviqui Forero Activo

    Ubicación:
    Aragon
    Motor:
    1.7 CRDi 141 CV
    Versión:
    Tecno
    Color:
    Moon Rock
    No pienso cambiarlos solo era una pregunta con lo que tengo el modem TP-Link con una sim ya me marca los radares y el navegador lo veo bien, tambien tengo el Menavrus pero lo probe y nada cuando esta funcionando la mitad de las teclas no hacen la funcion que han de hacer y con los mapas del igo no hay sonido y los del navitel del 2013, ya voy bien con lo que tengo, todo lo demas son experiencias, perdona el tocho.
     
    Última edición: 22 Nov 2016
  11. jose1975

    jose1975 Forero Novato

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Klass
    Color:
    Polar White
    Hola JKD, perdon por mi ignorancia, creo que me he perdido en algun momento, ¿Como compruebo el archivo AMK.LMF para saber si el valor es 1 ó 0?, ¿Como puedo saber que software tengo?.He mirado en la sd y si tengo ese archivo AMK.LMF, eso significa que puedo clonar la tarjeta y funcionaria en mi Tuson?
     
  12. Daviqui

    Daviqui Forero Activo

    Ubicación:
    Aragon
    Motor:
    1.7 CRDi 141 CV
    Versión:
    Tecno
    Color:
    Moon Rock
    Para saber el software que tienes pulsa una vez esta Boton_Setup.JPG y cuando te salga otra pantalla tenla pulsada y te saldra una pantalla en blanco y negro y veras toda la informacion del software.
     
  13. JKD

    JKD Forero Experto

    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno Aut. 4x4
    Color:
    Thunder Gray
    Si tu software está actualizado (posterior a la versión 20.003) y ya dispones de ese archivo, debería funcionar en una tarjeta sd no original. En cuanto a si la versión de tu AMK.LMF corresponde a la opción 1 o 0 es cuestión de probar pero hasta ahora parece que todos usan la misma. El contenido de ese archivo lo puedes ver con el Bloc de notas pero no edites el archivo no vaya a ser que con un pequeño cambio deje de funcionar ;)
     
  14. pakoscosta

    pakoscosta Forero Novato

  15. Mauro

    Mauro Forero Novato

    Motor:
    1.7 CRDi 141 CV
    Color:
    White Sand
    Hola a todos y felicitaciones a JKD por todo el trabajo realizado. Soy italiano y no sé español, yo uso el traductor de google, me disculpo por mi español. Yo quería saber si alguien ha logrado elevar el volumen del sonido de alerta de radar, de ser así, ¿cómo? Gracias a los que me quiere responder.
     
  16. nemon67

    nemon67 Forero Novato

    Ubicación:
    La coruña
    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno
    Color:
    White Sand
    Hola a todos ya clone la tarjeta y funciona perfectamente, solo quería saber donde puedo encontrar unos mapas actualizados para poder probar si funcionan. Un saludo y gracias de antemano.
     
  17. Juancar38

    Juancar38 Forero Experto

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno
    Color:
    Phantom Black
    En la página 5 del hilo "Actualización del navegador 2017". Es un post del compañero JKD.
     
  18. nemon67

    nemon67 Forero Novato

    Ubicación:
    La coruña
    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno
    Color:
    White Sand
    Gracias Juancar
     
  19. Juancar38

    Juancar38 Forero Experto

    Motor:
    1.7 CRDi 115 CV
    Versión:
    Tecno
    Color:
    Phantom Black
    De nada.
     
  20. nemon67

    nemon67 Forero Novato

    Ubicación:
    La coruña
    Motor:
    2.0 CRDi 136 CV
    Versión:
    Tecno
    Color:
    White Sand
    He instalado el mapa al qué haces referencia y buala, carreteras que antes no veía ahora aparecen. Gracias compañeros.
     
Este sitio usa cookies, propias y de terceros. Si se continúa con nosotros entendemos que se acepta el uso de cookies. Aceptar Más información